Emby Keeps Crashing

I have had emby installed for a few months and everything was working fine until recently.
It just stopped working and the service wasn’t running. I tried reinstalling it but got the error install error.
MichaIng helped with this with the following code:

sed -i 's#"$(curl -s "$INSTALL_URL_ADDRESS" | grep -m1 "browser_download_url.*emby-server-deb_.*_$arch\\.deb" | cut -d \\" -f 4)"#"https://github.com/MediaBrowser/Emby.Releases/releases/download/4.0.2.0/emby-server-deb_4.0.2.0_$arch.deb"#' /DietPi/dietpi/dietpi-software
/DietPi/dietpi/software install 41 # to rerun the Emby install

It installed again and worked. After I added media to the library I watched one show and then it crashed again.
I try to start it:
root@DietPi:~#

dietpi-services start emby

[ OK ] DietPi-Services | Root access verified.
DietPi-Services
─────────────────────────────────────────────────────
Mode: start
[FAILED] DietPi-Services | start emby

I ran the status:

root@DietPi:~#

service emby-server status

● emby-server.service - Emby Server is a personal media server with apps on just about every device.
Loaded: loaded (/usr/lib/systemd/system/emby-server.service; disabled; vendor preset: enabled)
Active: failed (Result: signal) since Sun 2019-04-07 09:23:50 BST; 15min ago
Process: 11095 ExecStart=/opt/emby-server/bin/emby-server (code=killed, signal=ABRT)
Main PID: 11095 (code=killed, signal=ABRT)

What can I do? I have paid for Emby Premiere and don’t want to use another platform.

I have noticed that as soon as i unplug my external usb 2tb hd where my media files are on that emby starts and runs.
As soon as I plug my external hd drive in emby works for a while and then crashes.
I have recently changed the filesystem from ext4 to exfat. Could this be the problem???

I’m in the process of changing it back to ext4. Will give updates about this.

It is indeed a filesystem problem. If the hd is formatted with ext4 and I add media to emby’s library it works.
But if the hd is formatted with exfat and I add media to emby’s library emby-server crashes and wond start up again until I remove the hd.

I wanted to be able to plug the hd into other devices like my windows pc or my nvidia shield.

canabino
Sorry for the late reply.

dietpi-services start emby

Similar to the service status command it needs to be “emby-server” :wink:.

Very interesting find with the file system issue, I will check that as well.


Ah you reported already on Emby forum. That’s good, let’s hope for a soon reply: Emby server crashes after a while - Linux - Emby Community

Possibly related:

Hmm just tried it on VM and works fine here.

How do you face the issue exactly?
You add the exFAT drive as Emby media library. Then you add media to it, e.g. via console or copying it from an external machine. Then you reattach to the DietPi and e.g. (re)scan the library with Emby?

It possibly has something to do with that exFAT does not support UNIX permissions. But at least in my case the drive has full 777 permissions, so everything has full R/W access. Could you verify that?