dropbear to openssh

been using DietPi on a few devices, RPi2, RPi3, OrangePi Plus and oDroid C2

today i got my eMMC for my C2, put DietPi_v139_OdroidC2-arm64-(Jessie).img onto it, connected it to the C", took the SD card out and booted it up

found the IP address and logged in via SecureCRT, went through the usual updating system to 1.42, while it was doing that i changed the IP address in my router to something i could remember, i have my SBC’s high in the IP table range, between and

anyway, C2 is now assigned, router didnt kick up a fuss about IP conflict

finished updating to 1.42, rebooted, logged in with the new IP, time to setup, first things first, change Dropbear to OpenSSH so i can edit files from WinSCP, it installed, went through the motions, rebooted and boom, its now not connected, no where to be seen on my network, thought i made a mistake, reflashed the eMMC again, went through all the motion again, changed Dropbear to OpenSSH and yet again, no where to be seen

is it a new issue with 1.42?

trying to connect via in SecureCRT or WinSCP does nothing, doing an IP scan on my network doesnt reveal it connected, checking my router for connected devices doesnt reveal its connected, im stuck, big time

Not that we are aware of at the moment.

OpenSSH so i can edit files from WinSCP, it installed, went through the motions, rebooted and boom, its now not connected, no where to be seen on my network,

Can you ping the device?

Also, might be worth plugging in HDMI, see if there are any errors/issues reported on screen.

ping test revealed destination host unreachable, HDMi is isnt showing anything either

formatted the eMMC again, went through the motions, this time i didnt change dropbear to openssh, just put samba on from the dietpi-software, rebooted and nothing, dodgy eMMC i think

just put dietpi onto an SD card, changed dropbear to openssh, NFS server and samba installed, transmission installed, rebooted, all worked

took the SD card out, created an image, tried to put in onto the eMMC but it was to big

loaded up vmware workstation running ubuntu, installed gparted, mounted the USB in vmware, resized the partition on the SD card, unmounted it

back in windows, created another image from the SD card, put that onto the eMMC and back on the C2, boom it loaded, but now i am not sure if i can install software, let the testing begin

did i miss anything?

I’d like to add I’m seeing the exact same issue. I have a C2 with eMMC that had the official linux release on it and ran just fine. After finding DietPi I decided to give it a try. I removed the eMMC and installed DietPi on a sd card. I played around with it until I decided it would work for me. Installed the DietPi img on the eMMC and went through the setup procedure. After installing xfce4, vnc, samba & openssh (same setup as the working sd card) the system would never come back. No video at boot, heartbeat LED OK, no ssh replay.

Having read another email exchange in this forum, I decided to replace the /boot partition with the one from my sd card. Now the system with eMMC boots up and I can use vnc & ssh. However on the next reboot I’m back to a zombie system. Replace the /boot partition again and it works, reboot and it’s dead again.

Comparing the files between the working /boot and the non, I don’t see anything different. I’m at a loss.

cant get samba to install now

i installed transmission, netdata with success, trying different ways of installing

if i install nfs-kernel-server from apt, it works as it should, not tried samba yet
but NFS from dietpi-software (software additional or software optimized), my C2 wont come up from reboot, same with samba from software additional or software optimized