Docker compose Nginx Proxy Manager

as stated on the other forum post, if you go with a proxy software, you need to disable https on your web server hosting nextcloud and you need to change away from port 80 to 81. Your proxy will handle ssl and forward all request to nextcloud. usually it is not needed to have ssl active on any of your apps as all this should be handled by the proxy. Only thing you might need to check of your apps are able to work an a sub folder like

This way you would need a single certificate only. Usually your apps should have a wiki where it should describe how to use sub folder. Another option is to use sub domains. Something like this

You could mix it as well. All depends on your apps and how you could configure them

OK, thanks for help.

Hi, Joulinar I think You’re the only one who can help me :smiley:
Please don’t be mad.

I disable https on my Dietpi:

lighttpd-disable-mod dietpi-https dietpi-hsts dietpi-https_redirect

I uninstall certbot.

I forward ports on router like this:

external port:           host/IP           internal port:      protocol:
80-80                             8080-8080          TCP
443-443                         4443-4443          TCP

I install Nginx Proxy Manager like this:

version: '3'
    image: jlesage/nginx-proxy-manager
    network_mode: host
      - "/home/dietpi/.config/nginx-proxy-manager:/config:rw"

I change port for zigbee2mqtt:

    container_name: zigbee2mqtt
    restart: unless-stopped
    image: koenkk/zigbee2mqtt
      - ./zigbee2mqtt-data:/app/data
      - /run/udev:/run/udev:ro
      - 8081:8080
      - TZ=Europe/Berlin
      - /dev/ttyUSB0:/dev/ttyUSB0

I install Petio:

version: "3"

    driver: bridge

    container_name: "petio"
    hostname: petio
      - "7777:7777"
      - petio-network
      - mongo
    user: "1000:1000"
      - TZ=Etc/UTC
      - /home/dietpi/.config/petio/config:/app/api/config
      - /home/dietpi/.config/petio/logs:/app/logs

    image: mongo:latest
    container_name: "mongo"
    hostname: mongo
      - "27017:27017"
      - petio-network
    user: "1000:1000"
      - /home/dietpi/.config/petio/db:/data/db

I remove also from my


that /nextcloud :

'overwrite.cli.url' => '',

The strange situation is my Nextcloud works now on SSL but other apps don’t.
Can You help me with that?

you would need to create a proxy definition for each application in NPM

Thanks, I also get some info that I need to make New Proxy Host for every app in NPM. I need to make subdomains on no-ip for every app like:

you can use sub folder as well on NPM. See my PM. Just search the web on how to use sub folder

But I get info from Home Assistant suppport that I cannot use subfolders for that :confused:

in this case you need to use sub domain for HA application

How to manage additional sub domain, maybe contact NoIP directly.


sorry for the necro-bump, but I wanted to give my docker/nginx proxy manager an update now after a year of running good. how to do that and keep the settings?

I am stuck here and noticed that even portainer is old and wants to update.

Not sure how you setup NPM in first place but having a look to vendor docs might give an idea Upgrading | Nginx Proxy Manager at least if you used docker-compose.

I think I followed that tutorial back then to install it. the upgrading command gives me this:

What exactly you are trying to do? These are 2 different errors.

Did you try to install portainer or reinstall?

And docker-compose needs to be executed within the directory where you compose configuration file is located.

1 Like

Joulinar saved me again. I updated both containers successfully now. Removed portainer using “dietpi-software” and reinstalled it again. That brought portainer to the latest version. Then I could update the NPM container using portainer.

Usually a simple dietpi-software reinstall <App ID> should have been sufficient to update portainer.

1 Like

I would also recommend installing watchtower for docker…keep the containers updated with the latest builds automatically

centurylink/watchtower - Docker Image | Docker Hub

1 Like

that gave me the blue error seen above. it worked manually though.

Originally, did you installed Portainer using dietpi-software?