Disable proftpd

Hi all i want to disable proftpd and use only when i need.
i tried with sudo systemctl disable proftpd.service
or sudo update-rc.d proftpd disable
But at the next reboot the proftpd is running again!
Any suggestion?

Seem that is a process launched by diet pi.
With dietpi-process i can change nice and cpu affinity… But how to disable?

DietPi disables the services from automatically running, so that they may be controlled by DietPi, you will need to mask the service to prevent it from running.

Disable:

systemctl mask proftpd

Enable:

systemctl unmask proftpd

Thanks a lot!

Has this changed?
I tried this method to stop squeezelite and mopidy to run when I don’t need them, but this is what happens:

root@OPiZero:~# systemctl mask squeezelite
Failed to execute operation: File exists

Strange, claims its already masked?

Try unmasking it and remasking it.

I have already tried. Same error.