Difficulty with Deluge and DietPi

I can’t, for the life of me, get Deluge (via WebUI) to download to the external HD I have attached to the Pi. It’s running Plex just fine off the same drive (also installed via DietPi) so I know it’s mounted and accessible.

I’ve tried creating a folder specifically for Deluge and changing the ownership from root:root to dietpi:dietpi after seeing that as a solution but that didn’t work. Admittedly, my Linux knowledge is sorely lacking but my Google-fu can usually make up for it.

I also was able to change the permissions to give read/write access to all. (I thought this was going to fix me but it didn’t.)

I went with Deluge as it had worked like a charm for me on my late PC (I’ve recently built a new PC but wanted to offload downloads to a different device) but am considering giving Transmission a go at this point if I can’t get Deluge configured properly. Any help here is definitely appreciated.

Hi,

many thanks for your report. I played a little bit with Deluge and an external USB stick. I was able to download a file to the stick without issues.

What file system format you are using on your external disk?