Different errors after update to V6.3

Hello everyone,

After update V6.2 to V6.3, I see this error messages:

After login as user (not root):

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

After root login:

DietPi | 22:46 | Wed 07/03/18
v6.3 | RPi 3 Model B (armv7l)
NULL: error fetching interface information: Device not found


Created by : Daniel Knight
Web : http://DietPi.com
Twitter : http://twitter.com/dietpi_
Donate : http://goo.gl/pzISt9
DietPi’s web hosting is powered by: MyVirtualServer.com

dietpi-launcher = All the DietPi programs in one place.
dietpi-config = Feature rich configuration tool for your device.
dietpi-software = Select optimized software for installation.
htop = Resource monitor.
cpu = Shows CPU information and stats.

How can I fix this problems?


Thanks for the report:

  • Which SSH server are you running (default dropbear)?
  • Please paste results ifconfig
  • Please paste results locale

Another problem I noticed: prior to 6.3, when changing the ‘NICE’ and priorities for a set of tasks (for instance to prioritise Roon/RAAT), DietPi was recording the changes and restarting with the modified parameters after a reboot/restart. From 6.3, parameters need to be changed after every restart.
Could you please check ?

Thank you for your answer! Here are the answers to your questions:

  • Which SSH server are you running (default dropbear)?

I use OpenSSH and I have checked my version:

dpkg --list | grep ‘openssh’

ii openssh-client 1:7.4p1-10+deb9u2 armhf secure shell (SSH) client, for secure access to remote machines
ii openssh-server 1:7.4p1-10+deb9u2 armhf secure shell (SSH) server, for secure access from remote machines
ii openssh-sftp-server 1:7.4p1-10+deb9u2 armhf secure shell (SSH) sftp server module, for SFTP access from remote machines

  • Please paste results ifconfig

eth0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether b8:27:eb:dd:53:22 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::9ade:d0ff:fe0e:b927 prefixlen 64 scopeid 0x20
ether 98:de:d0:0e:b9:27 txqueuelen 1000 (Ethernet)
RX packets 300265 bytes 26308665 (25.0 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 202074 bytes 29921308 (28.5 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1 (Local Loopback)
RX packets 17059 bytes 1671121 (1.5 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 17059 bytes 1671121 (1.5 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

I use a USB connection for more internet speed on the PI. That’s why he stands by eth1.

grep -ri ‘ACTIVE_DEVICE’ /DietPi/dietpi/func/obtain_network_details

IP_ADDRESS=$(ifconfig “$ACTIVE_DEVICE” | grep -m1 ‘inet’ | awk ‘{ print $2 }’ | cut -d: -f2 )


  • Please paste results locale[/quote]


cat /DietPi/dietpi/.network

I hope you can do something with this information? :wink:

Another ‘bug’, I use NGINX. But after every reboot I see an apache2 directory in /var/log. I remove it and do a reboot, but after de reboot he’s back.

I think, the problem is in /DietPi/dietpi/dietpi-ramlog:

#Main Loop
#Startup Phase (restore /var/log directory structure and files)
if (( $INPUT == 0 )); then

echo -e “DietPi-Ramlog: Starting”

#Create core directories, regardless of Logging mode.

- This prevents core system programs failing to write to their logfile (eg: logsave process will not terminate if the /fsck directory does not exist).

mkdir -p /var/log/apt &> /dev/null
mkdir -p /var/log/apache2 &> /dev/null
mkdir -p /var/log/fsck &> /dev/null
mkdir -p /var/log/news &> /dev/null
mkdir -p /var/log/samba &> /dev/null
mkdir -p /var/log/ntpstats &> /dev/null

Maybe you can make a check if Apache and NGINX is used? If no, then do not create it. Where is NGINX in this file? (I didn’t used samba, but there is also a directory in /var/log)


Unable to replicate here testing cron, all changes are saved and applied during reboots.

Which programs did you change the options for, that are not being applied after reboot?

Thanks for the info, which user was you logged in as?

First as PI and then as root with the su command. I did cat /DietPi/dietpi/.network as root.

Thanks for checking. Used dietpi-process_tool. Will check again after update to 6.4 and report if still present.

Just checked. After reboot, one process (Roon Bridge) kept parameters given via process_tool. Others (RoonBridge Helper and RAAT Server) were dropped. Surprisingly, after power off/power on, the parameters changes were kept…