dietpi-update won't work on Pi 3 v115

Hello folks,


I’ve tried to get the initial dietpi-update to work soooo many times, it just won’t work.

All I did is a fresh install of v115 image which is the only one I could get for my Pi 3.
It always says GitHub is offline or unreachable.

I tried to edit dietpi-update file to replace $GITBRANCH by “master” at every line where the var was called. I tested the given url in my browser and it indeed downloads a zip.
The server version url returns 115 and 5 when tested in browser.

curl says there are illegal characters in link.

My Pi has static IP with google DNS, mask and gateway are ok, it is connected to the internet and can do antyhing BUT dietpi-update.

I tried with ethernet and two different wifi networks.

Any ideas people ?


Thanks in advance !

EDIT : maybe there is a way to manually update DietPI by manually overwriting the files in /boot/ with those from GitHub ? (I tried that and it said i was on 117 on reboot but dietpi-update still gave the same errors and I have no way of knowing it that way of updating isn’t missing some scripts or optimization that need to be processed …)

Hi Vince,

Thanks for the report.

We can try overwriting the dietpi-update script with the latest version:

wget https://raw.githubusercontent.com/Fourdee/DietPi/master/dietpi/dietpi-update -O /DietPi/dietpi/dietpi-update

Try running the updater now

dietpi-update

If issues persist, please post the error you see on-screen and we will try to find the cause. Thanks.

Hello, thanks for your fast answer.

Github is either offline or unable to connect. No updates applied.

This the standard error scripted in your update file.

Does it matter i used the move to external hdd script at first boot ?

Hi Vince,

Can you run the following command and let me know the results.
Before you run the command, make a note of the date/time on another system. I basically want to check for offset.

date

Also please run the following command:

curl -k -L https://raw.githubusercontent.com/Fourdee/DietPi/master/dietpi/dietpi-update > /DietPi/dietpi/dietpi-update

Try running dietpi-update again and let me know if you receive the same error.

Hey I’m back,

Sorry for not answering before, work…

I couldn’t try that, simply because it finally worked with no explanation on the tenth try, ethernet with zero conf.

But i think I see what you mean there. And actually my pi never asked any ntp server for time, and was one month late at boot.