Dietpi update failed from v8.5.1 to v8.7.1

Creating a bug report/issue

Required Information

Steps to reproduce

Expected behaviour

Actual behaviour

Extra details

Additional logs:

curl: (22) The requested URL returned error: 503

Could you try running following manually

cd /tmp
curl -sSfL0

Just to check what your issue might be

This is the output that I got.

hmm for me this is working fine and I get the script displayed. Could do a reboot and try again?

Actually I rebooted.

Also I did

apt update


apt upgrade

as well.
Still same issue

still I’m not able to replicate. Might be something local interfacing with the access to GitHub. Any special network security that could have an influence?

any further ideas?

Since I am using a Virtual Machine I haven’t set any network security. It’s kept with normal settings only.

But since you mentioned it I will try to do a git clone to see if it is having any unexpected behaviour

Normal git clone worked without any issue

This is an issue with the GitHub server, obviously just the one node you’re connecting to from your location: Error loading files on repository "Error 503 Backend is unhealthy" · Discussion #11915 · community/community · GitHub

It should solve itself over time, not sure where it makes sense to contribute to the discussion and name the exact IP that curl tried to connect to :thinking:.

hmm originally it has been opened in Feb. But some new reports on the last days. :thinking:

Is actually this one file affected only, or others as well?

curl -sSf

Ah, the version file did actually work, otherwise the update should have exited earlier :thinking:.