DietPi-TimeSync Waiting for time sync

Required Information

  • DietPi version - Last version, just downloaded it from the website
  • SBC model - RPI 3B
  • Power supply used - Original
  • SD card used Sandisk Ultra

I’ve just installed DietPi on my SD card. When I connect to my RPI from SSH I get this message ( DietPi-TimeSync Waiting for time sync ). It has connection to Internet because I’ve response from when I ping to the server.

I attached an image of the problem. It’s a fresh installation.

Sorry for my english, is not my native language. Than you!

Welcome to our community.

Pls can you have a look to the log once the time sync finished/timed out

journalctl -u systemd-timesyncd.service

One hint for the forum usage. If possible, try to avoid screen sprints. You should be able to copy everything from SSH terminal directly :wink:

Okk, sorry! I’ve to use Pastebin to post the log because the link restriction for new users.

Usually, it should be possible to copy the content of a log directly into our forum.

Coming back to your issue. Looks like all global Debian NTP Time server are not reachable for you.

systemd-timesyncd[235]: Timed out waiting for reply

Could there be anything on your network blocking access to NTP server on port 123? Do you have a local NTP server that could be used instead? Some router offering NTP functionality.

I’ve been using TL-R600VPN for years as switch with the default configuration, but never had any problem in the past with Torrent files, HTTP servers,… and does not seem to have blocked port 123. I don’t know if this router can work as a NTP server but I’ll try connecting the RPI directly to the main router on my home to see if I’ve the same problem.

Edit: I’ve also tried with other NTP servers as

Thank you!

I’ve the same problem from my main router :frowning:… I don’t know what to try to solve this problem.

You could install tcpdump and check what packages are sent on your NTP request.

Once installed, on a first SSH window start package capturing

tcpdump -i any -c200 -nn port 123

On a second SSH terminal, restart the time sync

/boot/dietpi/func/run_ntpd 1

Thank you, I’ll try with tcpdump to figure out if my ISP is blocking NTP servers. For now I’ve found a partial solution, setting up the date manually through terminal, with “date -s ‘2022-08-30 15:14:30’”.

Now I can try DietPi! :slight_smile:

1 Like

not a real solution. Definitely you need to find out what is block NTP (port 123) inside your network or IPS