Dietpi Restore failed, even tried on a new flash of Dietpi

If I’m not mistaken, the AllowedIPs on b was wrong, but should have been or depending on the size of the VPN network, and/or LAN IP range if you need access through the VPN to other LAN services with are not connected to the VPN.

And the Endpoint at client config needs to be the public IP or domain, not the one within the VPN network.

Also be careful with disabling IPv6 at the server. All IPv6 requests of clients will then bypass the VPN: IPv6 leaks.

1 Like

Oppss, alright, thought it didn’t matter as long as they don’t have my WAN ip.
Have re-set up it again! Thank goodness there is PiVPN makes it a lot easier was manually generating the key and copy it one by one for each of my devices.

Right now everything is perfect! Thank you very much!

I’m not sure about the networking. I used this IP Subnet Calculator

to arrive at which will give me access of -
/8 will be giving me this range “ -”.
I could have sticked with the usual 192.168.1.x. Switched to the 10, purely for typing a few number lesser :rofl: but will not need more than 254 iPs. in my setup.

Ah that explain why local ip don’t work. Wanted to rule out is a port forwarding issue previously.

Alright, will read up more on the IPv6 leak. As of now my connection of VPN is purely connecting back home. Afraid that I will break other stuff for now.

Thank you very much still for the help!

Ah, I think I mixed it up: - is your LAN IP range while was your VPN internal IP range? And was the LAN IP of your VPN server? Makes sense then, with Endpoint = for testing, I guess.

Okay, however, great that it works now using PiVPN :slightly_smiling_face:.

Ah yes! Correct!
However I do realised something, sometimes when I connect to VPN.
I won’t be able to access internet, but Data Sent will be 1.0GiB+ within the first minute. Turn off and on, and it will work again. Will monitor and see how. Might be just a first boot issue.