DietPi - Problem with displaying the correctly web version(AdminLTE) of pi-hole when using PADD and speedtest mod

my system:

current DietPi v8.2.2 ARMv8 64-bit image
RPi 4 4GB
Pi-hole version is v5.9 (Latest: v5.9), AdminLTE version is v5.11.1 (Latest: v5.11), FTL version is v5.14 (Latest: v5.14)
Unbound
PADD v3.6.6
Speedtest Mod

The system has worked without any problems so far.
The system displays with PADD were also correct.
I once installed the speedtest mod, you can certainly argue about the sense.
There has been a cosmetic display issue in PADD since installation.
I tried to resolve the issue with the developer of the speedtest mod.
He found a temporary solution, but unfortunately this is no longer available after 24 hours.

sudo su
cd /opt/pihole/
rm version.sh
https://raw.githubusercontent.com/arevindh/pi-hole/master/advanced/Scripts/version.sh
chmod +x version.sh
rm /etc/pihole/GitHubVersions
pihole -v -a

Here is our conversation on Github:
https://github.com/arevindh/pihole-speedtest/issues/107

If I understand correctly, he suspects that my problem is due to installing Pi-hole with DietPi.

What I noticed is that the next day after the patch, the version.sh file has a different date than the day before and different content. So something is reverting the change back.

Sorry if the information is unprofessional, but I’m just a user with no experience in this regard.

Maybe someone has an idea what it could be.

Personally I don’t think there is any relation between DietPi and the /etc/pihole/GitHubVersions file.

For me it looks like this

root@DietPiProd:~# cat /etc/pihole/GitHubVersions
v5.9 v5.11 v5.14
root@DietPiProd:~#

And it is updating themselves on daily basis

root@DietPiProd:~# ls -la /etc/pihole/ | grep GitHubVersions
-rw-r--r--  1 root   root          16 Mar 16 18:08 GitHubVersions
root@DietPiProd:~#

It is a PiHole internal function. This is how the PiHole own cron looks like

root@DietPiProd:~# cat /etc/cron.d/pihole
# Pi-hole: A black hole for Internet advertisements
# (c) 2017 Pi-hole, LLC (https://pi-hole.net)
# Network-wide ad blocking via your own hardware.
#
# Updates ad sources every week
#
# This file is copyright under the latest version of the EUPL.
# Please see LICENSE file for your rights under this license.
#
#
#
# This file is under source-control of the Pi-hole installation and update
# scripts, any changes made to this file will be overwritten when the software
# is updated or re-installed. Please make any changes to the appropriate crontab
# or other cron file snippets.

# Pi-hole: Update the ad sources once a week on Sunday at a random time in the
#          early morning. Download any updates from the adlists
#          Squash output to log, then splat the log to stdout on error to allow for
#          standard crontab job error handling.
22 4   * * 7   root    PATH="$PATH:/usr/sbin:/usr/local/bin/" pihole updateGravity >/var/log/pihole_updateGravity.log || cat /var/log/pihole_updateGravity.log

# Pi-hole: Flush the log daily at 00:00
#          The flush script will use logrotate if available
#          parameter "once": logrotate only once (default is twice)
#          parameter "quiet": don't print messages
00 00   * * *   root    PATH="$PATH:/usr/sbin:/usr/local/bin/" pihole flush once quiet

@reboot root /usr/sbin/logrotate --state /var/lib/logrotate/pihole /etc/pihole/logrotate

# Pi-hole: Grab local version and branch every 10 minutes
*/10 *  * * *   root    PATH="$PATH:/usr/sbin:/usr/local/bin/" pihole updatechecker local

# Pi-hole: Grab remote version every 24 hours
8 18  * * *   root    PATH="$PATH:/usr/sbin:/usr/local/bin/" pihole updatechecker remote
@reboot root    PATH="$PATH:/usr/sbin:/usr/local/bin/" pihole updatechecker remote reboot
root@DietPiProd:~#

As you can see every day at 18:08, the version is grabbed from remote. Thearetically you should be able to test it yourself how it behave

pihole updatechecker remote

Without understanding all the details now, I almost imagined that something would be updated daily that would undo the fix.
Deactivating the corresponding part of the cron job doesn’t make any sense, that deprives the checking the status of Pi-hole…
But thanks for the explanation.

What I don’t understand is this:
On Pihole-speedtest github it says: “Feb 21 2022 Speedtest mod update, Pi-hole Web v5.11.1
But when I check Pihole Github and my own PiHole installation, there is no version 5.11.1 available for the web interface? And I cannot find any changelog for v5.11.1.
Latest release is this: https://github.com/pi-hole/AdminLTE/releases/tag/v5.11

So maybe pihole-speedtest expects something, what doesn’t exist?

What I can say is that speedtest mod is currently changing the web version (Pi-Hole) from v5.11 to v5.11.1, which is not the original. This is how it will be displayed on the Pi-hole Interface website. That wasn’t the problem for me, but since I also use PADD, v5.11.1 was criticized and displayed as not up-to-date, updates are available. As already described, only a cosmetic problem, but if you don’t constantly think about the background, you’ll be unsettled for a moment.

Ok now I understand, the creator of the speedtest just “forked” Pihole and makes his own thing? kinda ? :smiley:
But PADD doesn’t understand this, bc it uses the original source?
So it’s clearly a problem of pihole-speedtest, IMO.

I guess this mismatch will disappear as soon as original PiHole guys will release a version v5.11.1

At the moment it’s 5.11 https://api.github.com/repos/pi-hole/AdminLTE/releases/latest

Or the developer of this mod is holding back changing version numbers on his master branch and is creating a development branch. As soon as PiHole change the version, he could merge all his changes from dev to master, reflecting the new version.

Just to make it clear, there is nothing we from DietPi side can do on this behaviour.

Understood and thank you!