DietPi on Terramaster F5-422?

Has anyone tried to install DietPi on Terramaster F5-422?
What packages would I need to create ZFS from 5 HDD?

Truthfully, I would recommend a very light NAS build called OpenMediaVault
then install the zfs package, then build a pool with that

There isn’t any gui for zfs(openzfs) in Dietpi (I believe), you would side load/compile the modules and whatnot but it would all be command line, OMV has a zfs support in the omv-extras plugins and community apps

Just remember, zfs on par uses 1gb of RAM to 1TB storage space on zfs…if you have large drives, you might need to boost up the RAM

Man, that is one heck of a powerful little NAS box!

Looks like you could pull the “stock” os on the internal USB drive, and swap in another and test it…just remember back up any/all data
How to change your Terramaster software for something better (LONG.) : TerraMaster (

There is also TrueNAS Core (formerly freenas) as an option

With that said…if you want to give it a whirl
Install and Setup ZFS on Debian 11 | Bots! (
Install and Setup ZFS on Debian 11 (

Just found this as well…no need to install/run ZFS…run SnapRAID for parity, and MergerFS to combine all drives into one large filesystem/folder

SnapRAID and MergerFS on OpenMediaVault - Networkshinobi
(format drives BTRFS then setup the SnapRAID and MergerFS…looks alot like UNRaid)

Thank you very much for your help. It seems I may not need ZFS.
I installed DietPi and I like it very much but I run into a problem that is a showstopper - DietPi does not see the first and the second HDD, only the HDD at slots 3,4 and 5.
Maybe there is a proprietary Tetrramaster driver that takes care of it but I have no idea how to proceed.
I am using “ls /dev/disk/by-id” to see the available disks.

What does following gives you

lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid
root@DietPi:~# lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid
sda                  7.3T  0 disk
└─sda1 ext4          7.3T  0 part            73845cd0-da01-2a47-bc13-06bb992168d4 a273e52e-cd59-4bb4-bf0d-5b0f8a8d5407
sdb                  7.3T  0 disk
sdc                  7.3T  0 disk
sdd                  7.3T  0 disk
sde                  7.3T  0 disk
sdf                 29.3G  0 disk
├─sdf1 vfat           64M  0 part /boot/efi  6f401851-eaac-4272-8990-0610af6a7d21 5241-5109
└─sdf2 ext4         29.2G  0 part /          b9a7efa6-95d4-4577-b0e9-b8e68c5164d8 2804eb08-8cf3-417b-940b-22f16d0bb791

looks like 5 disk á 7.3 TB (sda > sde). sda seems to have a partition already (sda1). sdf is the disk your have the operation system running on.

It’s not the newest one but following guide could give an idea on how to create raid system using mdadm How To Create RAID Arrays with mdadm on Debian 9 | DigitalOcean

Thank you very much for your help.