DietPi for OrangePiZero Wifi & update problem

Hi,

I want to use OrangePi just for 1 running application and DietPi seemed to be the best solution as it supports also WIFI.

Here is the problem:
I sucessfully started system with eth0 static adress (it pings) and wifi with dhcp conneted to internet. I apply changes within dietpi-config
but after reboot wifi is not recognized. I have to disable/enable wifi, then it is recognized, then I have to put ssid&password again manually.
After reboot the same problem.

Another problem is that it seems it will always update by itself? How can I disable this?

When I put wirgin image on SD I had to configure, that is acceptible. But why it must also update?? Because it seems before update
it conneted to internet succesfully after reboot - but I only have seen it once, as immediatelly it started to update.

Is it possible to have really simple system that I put image on SD and it works after config??

Thank you for the help!

Hello

how can I contact developers of DietPi?

It seems the configurator is not writing any config file anywhere…

after reboot the wifi setting is completely forgotten…

also, why am I forced by configurator to install any software? I do not want any software, I want just run my own a single one apk.

I do not understand the principle at all, why I simple image can not be available without additional downloading and upgrading during
startup???

Does anybody know any other system for orangepizero that does not have users, upgrades, and many unwanted features?
Just linux with terminal (busybox) ??

about the config file, in my orangepi, i have a external hard drive hooked in in order to write the config.
about the software, you have to install software through the installer, because dietpi runs on ram, so programs must be adapted to work properly, and the installer is a way to do it without any struggle.

thanx for info

I have an idea, can you or anybody else help to sort out if it is feasible? :

the virgin image downloaded from dietpi.com is “jessie”, after power on it reboots and starts configurator…

I use also “jessie” for RPI and I know how to make files like wpa_supplicant, edit another files to make it work…RPI does not use configurator

if I somehow remove this configurator will I get simple jessie for OPI? I already seen that SD card has 2 partitions, one FAT and another
ext3 (?) for linux, this ext3 (?) seems to be the same as for RPI jessie

How can I remove this configurator for OPI dietpi jessie?

thanx

In that field, i’m afraid i can’t help you, i just have orange pi PC (rev 1) and i just had dietpi installed through installer, i don’t know how to bypass it, but i think if you access the sd card after the flash, and you delete the .sh file that starts the configuration, or simply on the /init.d it should have there something that makes it start, so if you delete it , it bypasses it.

i must say that this is just theory in my brain, you’ll have to test it out on your own, because i don’t have a second device to be testing it :confused:

Thanx!

I edited dietpi.txt file so it connects wifi immediatelly. But after 1st reboot it is written back to original :frowning:

So all next rebbots does not connect.

And it zeems configurator is not writing this file correctly

I think there is a bug


Unfortunately, for first run either wifi or eth0 is enabled, not both. This is really stupid. I need wifi on internet and eth0 static for local server.

Have a look here:

https://github.com/Fourdee/DietPi/issues/635#issuecomment-266006050



I have to disable/enable wifi, then it is recognized

Yep, John’s given the correct fix for this. Its a known issue experienced on “some” OPi Zero’s. Was the same for me in all my testing.
For some reason the xradio_wlan module does not init during boot. The fix linked above will create a service, that automatically completes a “reset” of the adapter during boot and should be functional.

Thank you for hints!
But it seems I am stupid :slight_smile:

the link shows command cat … to be applied
it is also written that actual image for download should have this already implemented? or it is only intention in comments by some people?

should it be applied after few reboots of the system ? no idea when and exactly how…

so I tried manually to make file /etc/systemd/system/xradio_wlan.service in second partition ext4 (?) on virgin image on SD card:

[Unit]
Description=xradio_wlan
After=network.target network-online.target

[Service]
Type=oneshot
RemainAfterExit=yes

ExecStartPre=/bin/bash -c ‘modprobe xradio_wlan’
ExecStartPre=/bin/bash -c ‘iwconfig wlan0 power off’
ExecStart=/bin/bash -c ‘ifup wlan0’

[Install]
WantedBy=multi-user.target





but then I have no idea how to apply these two commands:
– systemctl enable xradio_wlan.service
– systemctl daemon-reload
can thee be written in some files on virgin image on SD card before very first boot?

Paste this text into the command line, that all you have to do.

cat << _EOF_ > /etc/systemd/system/xradio_wlan.service
[Unit]
Description=xradio_wlan
After=network.target network-online.target

[Service]
Type=oneshot
RemainAfterExit=yes

ExecStartPre=/bin/bash -c 'modprobe xradio_wlan'
ExecStartPre=/bin/bash -c 'iwconfig wlan0 power off'
ExecStart=/bin/bash -c 'ifup wlan0'

[Install]
WantedBy=multi-user.target
_EOF_
systemctl enable xradio_wlan.service
systemctl daemon-reload

Thanx guys! :slight_smile:

Unfortunately I had to create that service file and executed just two systemctr
May be, it was problem of my terminal, I could not anyhow to execute cat, no enter working

Now I have 10usd cardsharing computer, see photo

Of course, I did not finish complete installation, I only placed oscam files and modified rc.local to start automatically

Now it is ready in 15seconds while raspberrypi B neede 1minute

Excellent! I hope sd card will not go corrupt




Still some questions:

I have not installed any software offered by configurator. So the real status in my application is the system has not been fully configured yet. What is the criteria “system is fully configured”?

When I power on it finishes waiting for login, but my oscam is already running. So dietpi-configurator does not start. Does this garantee that in the future no update would be executed?

If system is fully configured then after login the configurator would not start any more?

I use only wifi with dhcp to connect to interner, and eth0 static running on it cardsharing server. I even did not install usb. Is usb ftdi serial port converter support installed? If yes, would it be ttyUSB0?

Paste this text into the command line, that all you have to do.

The cat didn’t work for me but using nano to create the file and then running the 2 commands at the end did :slight_smile:

This is first OrangePiZero distribution (and I’ve tried 2 Armbian others) that has managed to get me up and running on WiFi :slight_smile:

I was beginning to despair!

Thanks very much :slight_smile: