Dietpi as openvpn client

Hello, I have openvpn server and there I generate ovpn files for clients like smartphones and laptops. I install openvpn [apt install openvpn] and send one file to dietpi and set it to autostart. My Dietpi works with that vpn but there are problems with DNS and it works very slow and I cannot install apps or even open dietpi-software.
I took about 20 seconds to login:

 DietPi v6.34.3 : 22:37 - Sun 12/27/20
 - Device model : RPi 2 Model B (armv7l)
 - CPU temp : 51'C : 123'F (Running warm, but safe)
 - LAN IP : (eth0)
curl: (28) Resolving timed out after 2000 milliseconds

Then I see that when start dietpi-software:

FAILED] DietPi-Software | Checking DNS resolver
ping: Temporary failure in name resolution

When I generate .ovpn file I set google DNS. That files works on my smartphone and linux laptops. How to fix that?


Hi Joulinar I find Your post on github but I don’t know I can change something now in dietpi.txt on /boot to fix my issue?

# Enter your Static Network details below, if applicable.

change DNS to
Edit, I change in dietpi-config>network:Adapters>ethernet and now I cannot login with ssh.


These are AUTO_SETUP parameter part of DietPi-Automation settings and will be applied on first boot of DietPi only, ONCE! Changing them will have no effect on your system. Can you check your DNS server settings

cat /etc/resolv.conf

Hi, thank again for answering me :smiley:
Now when I change DNS in dietpi-config>network adpapters>ethernet to google, my Rpi2 wont start. I will burn image second time and install fresh dietpi. I will change before installation in dietpi.txt on /boot to like above.
I will install openvpn [apt install openvpn] and start: openvpn --config dietpi.ovpn. Then when it works I will add that command to autostart. Do I have to move my file to /etv/openvpn/ folder?
Can You tell me some tips what to do also to make my .ovpn file to work?


I don’t use OpenVPN at all. Probably you can check on some OpenVPN specialized boards how to configure it correctly.

Hi, it works now. My Rpi 2 IP changed. :grinning: