Diet pi midnight crash

my Odroid HC1 only runs Plex server and motion eye surveillance software, both installed through Diet pi optimized software
every night Diet pi crashes and it’s impossible for me to find the cause
is there a logfile i can look into ?

Hi,

you could set log mode to FULL within dietpi-software. That should keep system logs in /var/log/

After setting Full → Go install
i get run into some problems


Mode: Update & upgrade APT

[ INFO ] DietPi-Software | APT update, please wait...
Hit:1 http://fuzon.co.uk/meveric all InRelease
Hit:2 http://fuzon.co.uk/meveric buster InRelease
Hit:3 https://deb.debian.org/debian buster InRelease
Hit:4 https://downloads.plex.tv/repo/deb public InRelease
Hit:5 https://deb.debian.org/debian buster-updates InRelease
Hit:6 https://deb.debian.org/debian-security buster/updates InRelease
Hit:7 https://deb.debian.org/debian buster-backports InRelease
Ign:8 https://download.webmin.com/download/repository sarge InRelease
Hit:9 https://repo.jellyfin.org/debian buster InRelease
Hit:10 https://download.webmin.com/download/repository sarge Release
Reading package lists...
[  OK  ] DietPi-Software | APT update
[ INFO ] DietPi-Software | APT upgrade, please wait...
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct                                                                                                                                                              the problem.
[FAILED] DietPi-Software | APT upgrade
 - Command: apt-get -qq upgrade
[ INFO ] DietPi-Software | APT upgrade, please wait...
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct                                                                                                                                                              the problem.
[FAILED] DietPi-Software | APT upgrade
 - Command: apt-get -qq upgrade
[ INFO ] DietPi-Software | APT upgrade, please wait...
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct                                                                                                                                                              the problem.
[FAILED] DietPi-Software | APT upgrade
 - Command: apt-get -qq upgrade
[ INFO ] DietPi-Software | APT upgrade, please wait...
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct                                                                                                                                                              the problem.
[FAILED] DietPi-Software | APT upgrade
 - Command: apt-get -qq upgrade
[ INFO ] DietPi-Software | APT upgrade, please wait...
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct                                                                                                                                                              the problem.
[FAILED] DietPi-Software | APT upgrade
 - Command: apt-get -qq upgrade

---------------------------------------------------------------------
- DietPi has encountered an error                                   -
- Please create a ticket: https://github.com/MichaIng/DietPi/issues -
- Copy and paste only the BLUE lines below into the ticket          -
---------------------------------------------------------------------
#### Details:
- Date           | Sun Aug  2 13:57:49 CEST 2020
- DietPi version | v6.31.2 (MichaIng/master)
- Image creator  | DietPi Core Team
- Pre-image      | Meveric
- Hardware       | Odroid XU3/XU4/MC1/HC1/HC2 (armv7l) (ID=11)
- Kernel version | Linux DietPi 4.14.180+ #1 SMP PREEMPT Wed May 20 14:57:20 UTC                                                                                                                                                              2020 armv7l GNU/Linux
- Distro         | buster (ID=5)
- Command        | apt-get -qq upgrade
- Exit code      | 100
- Software title | DietPi-Software
#### Steps to reproduce:
<!-- Explain how to reproduce the issue -->
1. ...
2. ...
#### Expected behaviour:
<!-- What SHOULD happen? -->
- ...
#### Actual behaviour:
<!-- What IS happening? -->
- ...
#### Extra details:
<!-- Please post any extra details that might help solve the issue -->
- ...
#### Additional logs:

E: dpkg was interrupted, you must manually run ‘dpkg --configure -a’ to correct the problem.

---------------------------------------------------------------------
[FAILED] DietPi-Software | Unable to continue, DietPi-Software will now terminat

pls can you run following as requested by the error message.

dpkg --configure -a

once done, do following

apt update && apt upgrade

Thanks, this worked
let’s see what the logfiles will bring up