Diet Pi Install Error - For Pihole

  • DietPi version |

  • Distro version | bullseye 0

  • Kernel version |Linux DietPi 5.15.32-v8+ #1538 SMP PREEMPT Thu Mar 31 19:40:39 BST 2022 aarch64 GNU/Linux

  • SBC model | RPi 3 Model B (aarch64)

  • SD card used | Samsung 16gb

Hello everyone, I am new to this forum, and I am having some issues downloading Diet Pi for the use of pihole, I have attached photos of the issue I am having, and was hoping someone could steer me in the right direction. Apologies in advance, if there are any format errors, and if I am missing any information. Thank you in advance

Welcome to our community.

Your system is in read only mode. Usually this is indicating file system issue like data corruption. Can you check for kernel error messages.

dmesg -l err,crit,alert,emerg

Btw, no need to do screen prints. You should be able to copy everything from SSH terminal directly. :slight_smile:

1 Like

Thank you for the advice, this is what I got

root@DietPi:~# dmesg -l err,crit,alert,emerg
-bash: /usr/bin/dmesg: Input/output error

Does your system is running on a SD card? Looks like it is not accessible anymore

Yes, it is running off a micro SD card. I am going to get a new one and will see if that helps

Was this a new installation or already running for some time. Theoretical you could try to reboot to see if this might gonna help for the moment.

New install, I tried around 4 times with the same result, so it does look like is leaning toward a SD card issue

If you have a USB pen stick you could try to boot from it.

You have a RPi3B or 3B+ ?

The 3B, but you are a life saver!!! I used a new SD card and everything is working! I cant believe I overlooked that, once again thank you so much.

ok good it is working now.