Desktop Environments lagging badly on Odroid

Good morning all. So, I installed a fresh run of DietPi for the Xu4 and got everything setup in the CLI with no problems. I then added XFCE to the build and set the login to auto launch and login to the Desktop. So, this part worked fine but once inside, the system started to lag in an extremely direct way. Mouse movements would take around half a second to register and were very sluggish. If I tried to open any applications (even the terminal), it would sometimes work but most of the time it would simply lockup with the spinning mouse indicator, never to move again until I restarted.

I’ve since cleared the SD card to try doing this again from scratch to see if I’ve missed something or it was just bad luck, but this will be the 3rd time I’ve tried this with the same results. Switching from XFCE to LXDE yielded the same results. When I put a regular Armbian distro on, the desktop works just fine with no lag so I don’t assume it’s a hardware problem.

So, any thoughts or has anyone seen this behavior and found a way to resolve it?

Thanks in advance.