Deluge - migrate from OSX

I have deluge running on osx currently but would like to migrate it to DietPi. There are a bunch of torrents already setup, but I’d like to have them follow me over as well. In the past, when I migrated to a new Mac, I just copied the config folder over and the next time I launched deluge it had everything in there ready to go. I just had to adjust some of the settings, but that was trivial. Very simple, to be honest. However, I’ve tried to do that same config copy on DietPi, but I’m running into issues…

  1. Is there a proper way to migrate from OSX to Linux?
  2. Where exactly is the config folder on DietPi?

On DietPi the config files are placed in: /mnt/dietpi_userdata/deluge/.config/deluge

The run users home /mnt/dietpi_userdata/deluge, not sure where the databases are stored, but if not inside the above, they are in default location from the Debian APT package, possibly /var/lib/deluge.

I have to do a test install to check.

Generally when moving databases you should check out general migration guides. In some software cases you cannot simply copy the database, as different versions have different database structures and require a migration step, that is in most cases only possible when moving to a higher software version, but not backwards.

Not sure how this is in case of Deluge, but at least I would check this out and compare the version numbers on your OSX with the one from Debian:
In case of mismatch check if some database migration is required and how to achieve that.

Generally I would recommend to install Deluge via dietpi-software first and move in your configuration (at best by comparing, since it might be quite different on OSX and Debian?) and database afterwards. Perhaps the GUI even allows to import from a database file/dump?

Thanks for the info! In OSX, the .config folder is directly under the ~ home folder in a folder called deluge… this is basically the same way I’m seeing the folder in DietPi as well… However, when I tried to migrate the folder over, it didn’t pull any of the settings nor torrents over… normally, you just copy that folder into the new spot, reload deluge, and everything is back… not this time…

I decided to just cut my losses and rebuild the settings from scratch. It’s not the end of the world, just a bit of a hassle. I will keep the old deluge up until my seeds finish and then slowly remove them. I just wish there were a good way to bring everything over… going between OS’s is more of a hassle than I thought…

You might want to try copying the files to the users home /home/deluge/… as well. We have an open issue where at least some auth file is still searched in the above home even that we change this via systemd unit environment variable.

well, what’s odd is that I have deluge working now but I can’t tell where the files are actually being put as far as config. I just ran a few tests by bringing down deluge and renaming the various config migrations I put on the locations below. The one in var/lib didn’t seem to recreate itself, so I don’t think that’s the right place. The one in user data, however, did recreate the folder, so I think that’s the spot… however, what’s odd is that once I let it recreate the folder, I couldn’t move my old config back into place… it would start the service but never actually bring my old stuff back… so, I think there’s still something missing in there… I ran a reinstall on deluge and did a quick comparison to the files on the Mac. The .torrent files are in the state folder. I was able to copy these over to the Pi, then import those torrent files. Copying the actual downloaded files over to the new download location and doing force re-check got everything back in order. I think I’ll be ok for now. It’s not quite as simple as a copy, but I think it’s good enough :slight_smile:

Thanks for the assist…

Saw this line in the install: cp -f 45.deluge_web.conf /mnt/dietpi_userdata/deluge/.config/deluge/web.conf
I guess that is proof of where the config lies… now, if I could just figure out why it won’t take the config as a whole from the Mac…