Dashboard using wrong port?

I’ve updated Dashboard today to 0.5.1, and tried to login with port 5252, but it wasn’t reachable.

I hadn’t used Dashboard in awhile, so I surfed around and found that some people used 8088, so tried that, and was successful in getting in.

Should I change this in the config.toml file? Does it matter? Is there a “better” way to change it?

The port has been changed on one of the last DietPi version due to some conflict with other application and has become 5252. Using 8088 would be the old one. What is the version of DietPi you are running?

I’m on 8.1.2 and Dashboard 0.5.1

What does the config.toml file say?

TCP network port
port = 8088


tls = false
cert = “/path/to/cert”
key = “/path/to/key”

Usually this should have been switched to new port automatically on dietpi-update. Anyway you could change port inside config.toml manually.

I mean, I know I can edit the port in the config file.
I just don’t understand why it didn’t change when I installed the update.

it’s not the Dashboard update. It’s the dietpi-update to version 7.9. Usually all updates are incremental


It was/is a yes/no question. Maybe you hit no? Could that be?

Btw: that’s the code to change

G_CONFIG_INJECT 'port[[:blank:]]' 'port = 5252' /opt/dietpi-dashboard/config.toml

Ah could you check if following (still) existing and if it contains something?