Couple of minor issues with Raspberry Pi Zero W

Just wanted to report a couple of minor issues I’ve enocuntered with the Raspberry Pi Zero W - know it’s fairly new but haven’t seen any other reports on these and figured it might help.

With a fully updated v146, the first problem I’ve had is SSL not working (at least on built in wifi). I can actually provide a solution to this as it was the same problem that existed by default on the Pi 3 when it was released. Simply edit /etc/ssh/sshd_config and add this to the end:

IPQoS cs0 cs0

This should fix it. This seems to be very specifically related to the Pi Zero W, as I have both two normal Zero’s with usb wifi, and another Zero with a “HubPiWi” attached (fantastic little screw-on board that adds three powered USB ports and wifi). and none of those have this issue.

Second slightly larger issue - first occurs during setup and is actually annoying as you get kicked out to terminal until you run the echo command, and you can’t enter wifi details at all before it tries, not that it makes a difference - is that NTPD appears to not be able to connect or times out ever, so the date and time on the clock will be wrong which leads to Firefox not being happy loading webpages. Again this seems to be exclusively an issue with the Zero W as the other three Pi Zero’s are fine with NTPD, and it happens on every boot too.
(Sidenote - perhaps if no ethernet is detected an earlier option to input wifi details could be implemented?)

Absolutely LOVE DietPi and use it on a total of five Zero boards, a Pi B (as TOR hotspot), and my Pi 3 these days. The performance turns all of them into actually very usable computers for whatever task I want to set them to, and just thought with the W being a bit less common right now these bits might be helpful to pass along. Superb work regardless!


Many thanks for the feedback.

NPTD is launched during each bootup, and once it completes, the program exists. So after entering WiFi details, a little time after (usually 5 seconds), ntpd will update time. Then DietPi-Software check for ntpd will complete successfully.

WiFi creds can be pre-defined after writing the image, and, before power on:

In regards to preventing NTPD wait, without a connection, i’ll look into this:

I’ll look at it again but I’m fairly positive that NTPD never updated the time on the W, even after wifi and internet access were established for hours. Just updated to v147 so will check later on that.

I’ve also had a minor problem in that using Esc to go back through menus in dietpi-config/dietpi-software doesn’t work on my (Nintendo-branded) bluetooth keyboard but I’m willing to put that down to hardware quirk. :wink:

Again, fantastic work on DietPi in general. Had it running Alexa with no problems in the past and probably going to work on getting a headless version w/wakeword going at some point. Perhaps that could make it into DietPi’s optional software to automate the install some day.
For reference:

EDIT: Went in and manually made sure it was still set to the recommended time sync, rebooted. Three hours since and it’s had full wifi the entire time and it hasn’t updated the time. Again, it’s still only failing to do so on the Zero W.