Connecting NTFS drive crashes RPi4- power issue?

Running an RPi4 on a clean install of Dietpi 7.3.2 off of a USB connected NVME running headless. Seems fine.

Now connecting a 5TB NTFS 2.5" drive over USB to the second USB3.0 port seems to cause the system to crash. I tried connecting it while running Dietpi-drive_manager. Drive_Manager just closes, and then all other commands stop working.

[FAILED] DietPi-Drive_Manager | Failed to remove scripts working directory: /tmp                   /DietPi-Drive_Manager
root@DietPi:~# htop
-bash: /usr/bin/htop: Input/output error
root@DietPi:~# nano /boot/dietpi.txt
-bash: nano: command not found
root@DietPi:~# ls
-bash: ls: command not found
root@DietPi:~# dietpi-config
-bash: /boot/dietpi/dietpi-config: /bin/bash: bad interpreter: Input/output error
root@DietPi:~# reboot
-bash: reboot: command not found

Trying to boot with the drive connected results in the Rpi4 being inaccessible when headless.

Is this consistent with insufficient power? I’ll invest in a cable to separately power the drive but wanted to check first.

Hi,

usually we recommend to have external drives powered externally to avoid power issues.

what happen if you connect the 2nd drive to one of the USB2 ports?

Are you able to check for kernel error massages once your system fails?

dmesg -l err,crit,alert,emerg

After I connect the drive I get nothing. But before I connect the drive I get:

[    4.966452] Under-voltage detected! (0x00050005)
[   17.060163] Under-voltage detected! (0x00050005)
[   47.300189] Under-voltage detected! (0x00050005)
[ 1188.356210] Under-voltage detected! (0x00050005)
[ 2089.508141] Under-voltage detected! (0x00050005)
[ 2988.644137] Under-voltage detected! (0x00050005)
[ 3530.948138] Under-voltage detected! (0x00050005)
[ 3889.796153] Under-voltage detected! (0x00050005)
[ 4788.932652] Under-voltage detected! (0x00050005)
[ 5331.236130] Under-voltage detected! (0x00050005)
[ 5688.068147] Under-voltage detected! (0x00050005)
[ 6589.220129] Under-voltage detected! (0x00050005)
[ 7131.524127] Under-voltage detected! (0x00050005)
[ 7488.356163] Under-voltage detected! (0x00050005)
[ 8389.508132] Under-voltage detected! (0x00050005)
[ 8931.812101] Under-voltage detected! (0x00050005)
[ 9288.644134] Under-voltage detected! (0x00050005)
[ 9407.588123] Under-voltage detected! (0x00050005)
[10187.784171] Under-voltage detected! (0x00050005)
[10732.100120] Under-voltage detected! (0x00050005)
[11088.932094] Under-voltage detected! (0x00050005)
[11558.660105] Under-voltage detected! (0x00050005)

I think I’ll try a cable that separately supplies the drive.

You have the message right from the start of the system. Ensure your device is correctly powered

Good point. I had switched the power adapter for what I thought was beefier, but that was creating errors. Switched that back, no undervolt errors before or after plugging into USB 2.0 port.

Plugged the 2.5" HDD into the USB 2.0 port, device did not crash immediately, but on running dietpi-drive_manager had the device hang and:


/boot/dietpi/func/dietpi-globals: line 464: mawk: command not foundnux-gnu/libne/boot/dietpi/func/dietpi-globals: line 471: stty: command not found
/boot/dietpi/func/dietpi-globals: line 473: ((: <= 120 : syntax error: operand expected (error token is "<= 120 ")line 160: ((: i<: syntax error: operand expect/boot/dietpi/func/dietpi-globals: line 479: ((: >= 7 : syntax error: operand expected (error token is ">= 7 ")
/boot/dietpi/func/dietpi-globals: line 774: /bin/rm: Input/output error
/boot/dietpi/func/dietpi-globals: line 464: mawk: command not found
/boot/dietpi/func/dietpi-globals: line 471: stty: command not found
/boot/dietpi/func/dietpi-globals: line 473: ((: <= 120 : syntax error: operand expected (error token is "<= 120 ")
/boot/dietpi/func/dietpi-globals: line 479: ((: >= 7 : syntax error: operand expected (error token is ">= 7 ")
/boot/dietpi/func/dietpi-globals: line 693: /usr/bin/whiptail: Input/output error
/boot/dietpi/func/dietpi-globals: line 159: stty: command not found
/boot/dietpi/func/dietpi-globals: line 160: ((: i<: syntax error: operand expected (error token is "<")

I think it probably is a power issue. Ordered a cable and we’ll see what happens.

looks like you are loosing connection to your USB connected NVME. Try to have external devices powered external. As well check if the power supply of the RPi is working correctly. Use an original one and not a mobile device charger.

Great, using a decent charger gives me no undervolting errors even when overclocking.

I then acquired a dual USB power to separately power this USB drive here- https://www.amazon.com/gp/product/B00VJ94C4G/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

Connecting the power end of the HDD cable to a 2 amp charger then seemed to do the trick.

I first plugged the data end into the RPi4 after the power cable while the RPi4 was on and it seems to have made it crash and lock up. Restarting the RPi4 fixed this. Ran dietpi-drive_manager and the system automatically installed NTFS drivers and the drive mounted smoothly with decent benchmarks

I got these messages, but I assume that’s fine.

[    0.444739] bcm2708_fb soc:fb: Unable to determine number of FBs. Disabling driver.
[    2.341907] sd 1:0:0:0: [sdb] No Caching mode page found
[    2.341914] sd 1:0:0:0: [sdb] Assuming drive cache: write through

Thanks for your help! Hope this helps other people running int odrive issues.

Great :slight_smile:. Yes those three “errors” are expected with USB drives attached and with no screen attached.

I got this problem too, and I fixed it with using a power supply for the external 2,5" drive.
Cheers

It’s always recommend to use a dedicated PSU for external HDD.