cloudshell display

hi all,

i have dietpi 0.97 running on my odroid xu4 and i have a cloudshell case.
after installing the software everthing was fine, including the small display.

now i tried to mount my usb disks, but i couldn’t mount because the running kernel doesn’t have xfs support.
see bugreport Reference CODE: 001e06300ee9-1.

to solve the problem, i downloaded the kernel sources from hardkernel (git clone --depth 1 -b odroidxu3-3.10.y) and compiled a kernel with xfs support.
after installing the new kernel with xfs support, everything works fine, i can mount my disks, but now the display in my cloudshell case keeps dark.

my question is, do you use a special kernel version for this display?
any ideas why the display doesn’t work now?

Hi Duc,

DietPi for Odroid XU4 is based on Meveric’s image. No idea what the compile options are for the kernel. However, when I upgrade the kernel from his repo, my cloudshell breaks also.

I’am having similar problems with the official HK images. It looks like the kernel is missing a compile option that is required for cloudshell display.
Please see my post here: Cloudshell no longer supported? - ODROID


i tried this and now my display works again

sudo -s
echo "options fbtft_device name=hktft9340 busnum=1 rotate=270" > /etc/modprobe.d/odroid-cloudshell.conf
echo "spi_s3c64xx" >> /etc/modules
echo "fbtft_device" >> /etc/modules

Yep: Cloudshell no longer supported? - ODROID

another question. how can i use this little display script (dietpi_cloudshell) on another distro?
i tried to install openmediavault at dietpi, without success. now i wil ltry to get the display running at omv.
any hints?

Hi Duc,

DietPi-Cloudshell is only available and supported for DietPi images. This is because i’ve coded DietPi-Cloudshell to integrate with a DietPi system (eg: usb mounts, dietpi version/info etc). You are free however, to modify the sourcecode to work with non-DietPi systems.

Here is how we launch DietPi-Cloudshell after automatic login:

Not heard of openmediavault. What issues did you experience?

thank you, i will check this out.
openmediafault is something like freenas. a pretty good web based administation tool. maybe it’s better to integrate it in dietpi, don’t know?

btw. dietpi-cloudshell displays only the first usb disk. i have a external 4bay usb case from fantec connected, in the cloudshell case i have no disk. but i see only the first drive…

DietPi was designed to allow for 1 dedicated external USB drive. This allows us to use /dev/sda1 as the mount point. If you want to add more drives, you will need to edit /etc/fstab and use UUID’s for each drive.

As for DietPi-Cloudshell, the same applies, it only expects 1 USB drive and has been designed around that system.
You can change which drive/mount DietPi-Cloudshell shows stats for: Line 3 of /DietPi/dietpi/.dietpi-cloudshell

I’ll take a look at openmediavault and see if we can create an optimized installation for it.

it works :slight_smile:

i copied the /Dietpi/dietpi folder to my omv installation and start dietpi_cloudshell via .profile of user root.

with a few changes in dietpi_cloudshell it displays the total disk size and so on.



		if (( $HW_MODEL < 10 )); then
		elif (( $HW_MODEL >= 10 )) && (( $HW_MODEL < 20 )); then
		elif (( $HW_MODEL == 20 )); then

		df -h > $TEMP_FILE

		STORAGE_FLASH_TOTAL="$( cat $TEMP_FILE | grep $STORAGE_FLASH_PATH | awk '{print $2}')B"
		STORAGE_FLASH_USED="$( cat $TEMP_FILE | grep $STORAGE_FLASH_PATH | awk '{print $3}')B"
		STORAGE_FLASH_FREE="$( cat $TEMP_FILE | grep $STORAGE_FLASH_PATH | awk '{print $4}')B"
		STORAGE_FLASH_PERCENT=$( cat $TEMP_FILE | grep $STORAGE_FLASH_PATH | awk '{print $5}' | sed 's/%//g')


		#renew temp_file with disk data 
		#check for USB mount
		if (( $(cat $TEMP_FILE | grep -ci -m1 'total' ) == 1 )); then
			STORAGE_USB_TOTAL="$( cat $TEMP_FILE | grep 'total' | awk '{print $2}')B"
			STORAGE_USB_USED="$( cat $TEMP_FILE | grep 'total' | awk '{print $3}')B"
			STORAGE_USB_FREE="$( cat $TEMP_FILE | grep 'total' | awk '{print $4}')B"
			STORAGE_USB_PERCENT=$( cat $TEMP_FILE | grep 'total' | awk '{print $5}' | sed 's/%//g')

			Percent_To_Graph $STORAGE_USB_PERCENT

thank you very much for your help.


I have the same problem, i can’t read xfs file system, please duc, can you share your xfs compatible kernel?


PD: I have the orange pi PC