Cloned sdcard, now getting 'kernel panic - unknown block'

I am using an 8gb sdcard (class 10) for dietpi on a Raspberry Pi 3, wanted to expand storage by cloning it to a 32gb card (Sandisk Ultra) with windows win32diskimager tool, cloning went well but upon trying to boot with the new sdcard I get:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2)

Why is that? How can I fix?

I know that the sdcard as it will will be only 8gb, but I wanted to expand resize2fs later after boot, but it doesn’t work. tried resizing with a linux machine, same issues, tried doing an fsck on linux, fixed some stuff but still nothing, always kernel panic.

Any working method to clone DietPi without losing all the settings?

On the 8GB installation:

  1. Plug in USB drive (if one doesn’t already exist)

  2. Run dietpi-backup

  3. Under location menu, select the USB drive (eg: /mnt/usb_1/dietpi-backup.

  4. Select Backup to create a backup.

  5. Write a DietPi image to your 32GB card and power on

  6. Once installation is finished, run dietpi-backup

  7. Select location as usb drive

  8. Run restore