Clicks with 24 bit data RPi 3 B+ -V90-DAC

Hi; Pretty new to Rpi and Linux but computer savvy in the Wintel world. I have an RPi that I bought from Jriver with an installed JRMC server and player. It is connected to my network via wired connection and via USB to a Music Fidelity V90-DAC. Using JRMC to push files from either my PC running the JRMC server or from a network drive via the onboard server instance, I can play files up to the max resolution of the DAC (96/24) with no audible issues.

I decided to try a Roon/Tidal system. I tried Ropieee and got clicks playing high rez files. I tried dietpi with the allo gui and also get clicks. I updated the dietpi install via console commands (PuTTY), reselected the USB DAC and I still get the occasional click playing 96/24 files. It’s like listening to clean vinyl, just a pop now and then. If I use JRMC to send the same files to dietpi via DLNA i get the same pops. Not Roon or Roonbridge specific, OS specific it seems. If I tell Roon to limit bit depth to 16, the 96/16 stream works fine and sounds fantastic so this is a technical problem that can be satisfactory worked around but the engineer in me wants to make this work as I know there are other RPi based streamers working at 24bit and with much higher sample rates.

p.s If I disable the unneeded apps via the allo gui, the clicks remain.

This might be related to the CPU issue as per this thread:
I’ve been waiting for a response on that thread - it is marked solved but I have no idea how to implement the fix.

I saw that but it seemed to say that this was solved via an update and reselecting the sound card. That doesn’t seem to be the case as I have done that.

I just tried entering those commands and got “-bash: echo: write error: input output error”

Further, looking at interrupts shows all IRQ63 showing on cpu 0 so this is the problem but the fix seems locked out or something since I get the write error.