Clean install errors

Hello all,

Been fiddling with this problem for days.
I have a problem with my raspberry pi 4 2 GB.
I install a clean image of dietpi (31-03-2021) on a usb ssd, I connect it to the raspberry pi and then boot.
(Also get these errors when I boot from sd)
After a few seconds I get errors.
Have already downloaded the image(DietPi_RPi-ARMv6-Buster) several times.
Tried several utp cables but don’t work.
It seems as if I am not getting an ip number.
Last week everything still worked.


I press enter and login, then I see the following

Don’t understand anything at all anymore .

Who can help me so that I can use my raspberry again .


Greetings DutchFlash (Dutch,Newbie)

Hi,

can you try to disable IPv6. as well pls can you share ip a

Hi Joulinar,

disable IPv6 = is off now.

ip a

Suddenly it works again !!

I’m going crazy, :thinking:

I format the ssd and burn dietpi on it again. Plug the usb cable back into rpi4 (usb 3 port) and it suddenly works again.
(There is no sd card in de rpi4)
I have been doing this exactly the same for 3 days, and I kept getting an error installing.
Tried several times on different SSD´s and SD cards.
So just get an IP number again, so now i can log in to Rpi4 through (ssh)laptop again.
And now it suddenly works again, I don’t understand anything at all anymore.


Greetings, DutchFlash

well strange. Maybe an issue with the Ethernet cable? But good it is working now

I don’t know if it was the ethernet cable.(Tried 3 different ones )


Now have another problem, when I connect a second ssd to my rpi4. On the second usb3 port, I get an error message again.


If I connect it to a usb2 port, it will just work.?

Just give it a try. As well you need to ensure to have both SSD externally powered

I don’t have that option.

I am using this cable. SSD is in a 2.5 case.

well it might not be enough power if your connect 2 SSD. You could verify kernel messages dmesg -l err,crit,alert,emerg

Don’t get a notification, or am i doing something wrong.

root@Rpi4:~# dmesg -l err,crit,alert,emerg
root@Rpi4:~#

The Rpi4 is a few months old, with original Rpi4 power supply

I guess MichaIng could explain it better than I but the RPi4 is limited on the amount of power it can provide via USB. We had a couple of repots in the past on issues caused by this. Usually we recommend to use external power supply for external disks

Thanks, i will use the next time a external power supply for the ssd’s.