[cgi:error] Smokeping not showing new results after backup restore

Creating a bug report/issue

Required Information

  • DietPi version | G_DIETPI_VERSION_CORE=8
  • Distro version | buster 1
  • Kernel version | Linux xxx 5.10.103-v7+ #1529 SMP Tue Mar 8 12:21:37 GMT 2022 armv7l GNU/Linux
  • SBC model | RPi 3 Model B+ (armv7l)

Additional Information (if applicable)

  • Software title | smokeping
  • Can this issue be replicated on a fresh installation of DietPi? unknown
  • Bug report ID | 3f063a05-e31d-4abe-80f4-c27066c60ab5

Steps to reproduce

Surf to smokeping url

Expected behaviour

Smokeping should show old and new ping results

Actual behaviour

Smokeping shows only old results.

Extra details

/var/log/apache2/error.log shows:
[cgi:error] [pid 801] [client fe80::8d92:7bbf:1cba:7276:56477] AH02811: script not found or unable to stat: /usr/lib/cgi-bin/js, referer: http://vamana/cgi-bin/smokeping.cgi?target=Server

Those js/css folders are in /usr/share/smokeping/www as defined in smokeping.cgi in /usr/lib/cgi-bin/

probably better to check with application vendor on what the issue could be.

Smokeping seems to have been abandoned.
The thing is: it was working quite well before my attempted upgrade & restore.
It worked for so long that I can’t even remember how I’ve installed it. Which is also a reason why I would love to fix it before I try to reinstall it. Especially because of the historical data accumulated…

might be the /usr/share/smokeping/www permissions got jacked up on upgrade…double check that they are the correct ownerships

Yeah I tried that.
Didn’t help.
I had to start again fresh now since I depend on the tool.
Next time I’ll make an update backup of the SD-Card.
Lessons learned.