Can't upgrade to latest kernel (Rock64)

Hello DietPi community.

I really appreciate if anyone can help me out. I want to upgrade my kernel from 4.4.77-rockchip-ayufan-136 to the latest one (4.17)
Tried these methods already:

https://unix.stackexchange.com/questions/435897/dietpi-how-to-upgrade-my-kernel-version-to-latest-version
https://github.com/ayufan-rock64/linux-build/blob/master/recipes/kernel-upgrade.md

But the kernel remains everytime the same default (4.4.77-rockchip-ayufan-136). What am I doing wrong?

Version: DietPi v6.9

Following my researches. It looks like I need to get the Device Tree Blob (dtb) for my kernel. /boot/dtbs/

Maybe useful links:

Hi,
Did you manage to find a solution?

I’m in the same situation, installed DietPi and upgraded to v6.9 and no matter what I try (I’m not a linux expert), kernel doesn’t get upgraded to latest stable release - https://github.com/ayufan-rock64/linux-build/releases/latest

Appreciate if you or someone else can post some tips.
Thanks.

Hello!

Nowadays I don’t have time nowadays to tinker with my server.
But actually, I think we need to learn how to compile the kernel from source code and configure it to compile u-boot files too.
A professional here would be awesome here.
We still need the answer ^^

I don’t understand why it would be so difficult, according to
https://github.com/ayufan-rock64/linux-build/releases/tag/0.6.44 it should be enough to:

sudo apt-get update -y
sudo apt-get install linux-rock64 -y

There is also an option in dietpi-config to update firmware so I wonder if should be reported as a bug.

chestercs
Just for the record, we further discuss this topic on GitHub, if you are interest to join: https://github.com/Fourdee/DietPi/issues/1892

I’m also running 4.4.7-rockchip-ayufan-136 and was beginning to think that this was the best desktop install that I had yet seen on a Rock 64. However, I’ve just made the mistake of upgrading and updating the software and have hit the problem that I hit with two other microSD cards. When typing ‘startx’ I get a

Fatal Server error (EE) no screens found

report. I had assumed that, previously, I had tried to use suspect uSD cards, but that appears not to be the case.
Could it be that the update was trying to install a new kernel?
uname -a gives

 Linux DietPi 4.4.77-ayufan 136 #1

Yet another fresh install of something or the other coming up.

gregb49
What you mean by upgrading and updating the software: dietpi-update, apt update & upgrade or something else?

Until now, dietpi-update does not address the Rock64 kernel upgrade issue, that is topic here. apt full-upgrade will install a current kernel package, but it will not be placed into to EFI partition, thus have no effect.

But let’s investigate what’s the reason in your case.

Sharing the link with steps to upgrade to latest stable in case someone gets here

https://github.com/Fourdee/DietPi/issues/1892#issuecomment-408260405