Can't Install - Locks Up, No Video or SSH

I have an Odroid N2. It works fine on Armbian, but I wanted to try DietPi as it has some enhancements. However, I can’t get the current version to install. I am using the latest install file from this site: “DietPi_OdroidN2-ARMv8-Buster.img”.

I can get to the login screen, but if I enter my login info slowly, it will lock up and stop outputting video.
If I am quick with the login info, I can get to the software install window, but it usually locks up within 5 minutes, and I have to power cycle.

I tried using multiple microsd cards to see if it is a bad card, but I get the same result with 3 different microsd cards.

I burned the image with BalenaEtcher and followed the install guide: https://dietpi.com/docs/install/

Do I have a bad Odroid, or have others had this problem? Is there any way to use DietPi with my device?

Thanks.

if you are fast enough, you could look for kernel error messages.

dmesg -l err,crit,alert,emerg

MichaIng
any idea?

Would be interesting to know whether the pre-image works fine: https://dietpi.com/meveric/images/Buster/Debian-Buster64-1.2-20210501-N2.img.xz