Can't change audio card setting via dietpi-config

Hi, noob here… thanks so much for your work on simplifying the configuration of media servers!

Previously, I was able to use the dietpi-config tool to select which “soundcard” to use (HDMI vs. analog, for example). Today, I installed a HiFiBerry Digi+ card onto the Pi board. Now, I dietpi-config will display the list of soundcards, but it will not save the setting change. I was able to manually edit config.txt, but going back to the dietpi-config, it still shows the wrong selection. This tells me that the SD card isn’t write-protected, but beyond that, what do I need to do to fix this? No sound is coming out of the SPDIF output.

–Steve

Hi Steve,

Thanks for the report.

We can’t seem to replicate this here, so we’ll need more system info to diagnose. Please can you send me a bug report?
https://dietpi.com/forum/t/send-dietpi-a-bug-report/421/1

Also, when selecting the soundcard from dietpi-config, please can you run the following commands and paste results?

systemctl stop dietpi-ramdisk
systemctl status dietpi-ramdisk -l
systemctl start dietpi-ramdisk
systemctl status dietpi-ramdisk -l
cat /etc/dietpi/logs/dietpi-ramdisk.log

Thanks for the quick response and your willingness to look into this. I’ll follow up as soon as I can dedicate some time. Last night, I used another SD Card, and I manually built a Raspbian Lite system with just the necessary audio software and Logitech Media Server and Squeezelite player. It works, so that at least confirms my entire hardware, cabling and A/V receiver setup work.

I ran the bugreport, filled in the details, added the output of the commands from your post (regarding ramdisk), and here’s the code:

Reference CODE: b1cc8e09-8bd5-4043-a583-075d8ae26e9a-0

Thanks Steve,

Not sure what to make of this, DietPi-RAMdisk appears to be functional. Cant see any mention of “Read only” filesystem or issues in kernel logs.

Although, cat /etc/dietpi/logs/dietpi-ramdisk.log is empty and should not be. Does indicate an issue with either writing to disk, or service failing in most instances.

Not sure where to go from here, I believe the simplest/quickest solution would be to reinstall the system with a fresh DietPi image. Once done, setup the system exactly how you want it and enable the soundcard in dietpi-config.

I also noticed you enable OpenGL (vc4-kms-v3d). This is still in beta and currently buggy on 4.9.x kernel last time I tested it:
https://github.com/Fourdee/DietPi/issues/936#issuecomment-301316901
I would advise only enabling this option, after your system is setup and functional for a day or two. Then experiment with enabling OpenGL.
You can use dietpi-backup to create a stable restore point of your system.

Thanks for reviewing the data. I agree; it’s easier at this point to just start over from scratch. RE: OpenGL, that was just a case of me not knowing which graphics option to select. I’ll disable it. This is primarily a headless unit anyhow; I only had a monitor hooked up while setting it up; otherwise, I access it via SSH.