Can't access DietPi on RockPi4b after latest update

Creating a bug report/issue

Required Information

  • DietPi version | 8.21
  • Distro version | Armbian
  • Kernel version | Not Known
  • Architecture | ARMv8
  • SBC model | ROCK Pi 4b
  • SD card used | eMMC

Additional Information (if applicable)

  • After the latest update to 8.21, the USB HDD couldn’t be detected. After a reboot, I couldn’t access DietPi from SSH or HDMI. On my router the DietPi doesn’t show an IP address assigned to it.
  • Tried a fresh install of both Buster and Bookworm with the same results.

Steps to reproduce

  1. Can’t access Dietpi from SSH or HDMI
    Dietpi doesn’t get an IP address from router and the HDMI port has no output signal.

Expected behaviour

I see you deleted your comment on RockPi 4b usb not working
But it sounds similar, isn’t it?

It was a little similar at the start but mine doesn’t want to boot. Even after a fresh install. :upside_down_face:

ping @MichaIng

So you mean it also does not boot anymore with an older image? Can you try it with an SD card? Also probably powering is an issue (even if it worked before), so try to change PSU and/or power cable.

If boot fails in early stage, the only real way to debug it is via serial console. Do you have a USB-UART adapter for this?

If I install the buster image, it boots up and does the auto update as part of the first boot and automatically install the bookworm update because it is connected to the internet. When it reboots the second time, I can’t access it.

I will try to load the buster image again but not connect the LAN port and let it go through the first boot without being connected to the internet.

Can I run a command to stop the bookworm update for now?

Probably a misunderstanding. Our updates never invoke destro upgrades. If you have a Buster image, it will stay on Buster as long as you as a user do not trigger a manual upgrade to Bullseye. What happens is that your DietPi version is updated (regardless of the Debian version). This triggers the kernel update (the kernel version has no relation to the Debian version), which causes the problem. Of course you can boot the system without internet access, but you will not be able to complete the initial setup/configuration.

Thanks @Joulinar I understand better now about the kernel being updated and not the Debian version. I don’t have a UART-USB connector. How can I troubleshoot with no access to HDMI or SSH? It does boot after a fresh image install and I can access both HDMI and SSH to complete the initial setup, but after that reboot I can’t access HDMI or SSH. Is there a way to stop the kernel update during the initial setup? Thank you.

Do you have a spare SD card to test our new image with and see whether it shows the eMMC module as block device?

From there you could also downgrade the kernel.

Thanks @MichaIng I will try and let you know.

@MichaIng @Joulinar I decided to try just one more time installing the fresh bookworm image today, and low and behold it booted up but I’m having the same issue that USB3.0 ports don’t work. Only USB 2.0 ports are working like RockPi 4b usb not working - #24 by MichaIng

Workaround for now is to downgrade the kernel:

apt install --reinstall --allow-downgrades linux-{image,dtb}-current-rockchip64=23.02.2

Issue seems to be with the USB 3.0/dwc3 host controller driver, but it is beyond my knowledge. At least Armbian’s images now use the same kernel. To rule out that something is missing our end, it would be great if someone could test their Bookworm 6.1.50 image: Index of /dl/rockpi-4b/archive/

Thanks, Micha. I will downgrade for now. I know it will be resolved in the future. If I get a chance I will try to load an Armbian image from the archive you gave and let you know.

1 Like