Cannot mount Pi-hosted samba share

Solution at the end

I am unable to mount the samba share. I installed through dietpi-software. My smb.conf is as follows:


        workgroup = WORKGROUP
        server string = %h server
        dns proxy = no
        log file = /var/log/samba/log.%m
        max log size = 1000
        syslog only = no
        syslog = 0

        panic action = /usr/share/samba/panic-action %d

        security = user
        encrypt passwords = true
        passdb backend = tdbsam
        obey pam restrictions = yes
        unix password sync = yes

        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        pam password change = yes
        map to guest = bad user

        load printers = no
        printcap name = /dev/null
        disable spoolss = yes

        comment = DietPi Share
        path = /mnt/dietpi_userdata
        browseable = yes
        create mask = 0664
        directory mask = 0775
        valid users = dietpi
        writeable = yes
max connections = 8

Output of

ls -la /mnt/dietpi_userdata


total 28
drwxrwxr-x 7 dietpi    dietpi    4096 Jul 27 21:45 .
drwxr-xr-x 7 root      root      4096 Jul 29 03:45 ..
drwxrwxr-x 2 dietpi    dietpi    4096 Jul 27 21:55 Music
drwxrwxr-x 2 dietpi    dietpi    4096 Oct 30  2020 Pictures
drwxrwxr-x 2 dietpi    dietpi    4096 Oct 30  2020 Video
drwxrwxr-x 2 dietpi    dietpi    4096 Oct 30  2020 downloads
drwxr-xr-x 4 octoprint octoprint 4096 Feb 27 22:31 octoprint

When I try to connect from the finder on the Mac I get:
There was a problem connecting to the server “dietpi”
There server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and try again.

When I try to connect with the “go to server” function in the finder with smb:// (edited) it will not let me authenticate with the user dietpi and associated password.

I am able to ssh into the device no problem. I did try restarting smb service and restarting the pi.

If anybody can point me in the right direction it would be appreciated.

Edit to include copy of /etc/fstab

# You can use "dietpi-drive_manager" to setup mounts.
# NB: It overwrites and re-creates physical drive mount entries on use.
// /mnt/samba cifs cred=/var/lib/dietpi/dietpi-drive_manager/mnt-samba.cred,ioch$

tmpfs /tmp tmpfs size=1024M,noatime,lazytime,nodev,nosuid,mode=1777
tmpfs /var/log tmpfs size=50M,noatime,lazytime,nodev,nosuid,mode=1777

# MISC: ecryptfs, vboxsf (VirtualBox shared folder), gluster, bind mounts

/var/swap none swap sw

PARTUUID=907af7d0-02 / ext4 noatime,lazytime,rw 0 1
PARTUUID=907af7d0-01 /boot vfat noatime,lazytime,rw 0 2


sudo smbpasswd -a USERNAME

Then restart samba service


Not sure how it is on Mac but probably you would need to specify the share name as follows

Did you tried using an SMB App on a mobile device to check if it is working there?

Hey thanks for dropping in.

I have tried smb:// and it does not seem to let me authenticate with user dietpi.

I am unable to connect from android either. I don’t know how to start diagnosing this. I really wonder if there is something wrong with my smb.conf or is there a firewall problem from the pi side?

I updated my post include copy of /etc/fstab.

I found the solution see OP

does this mean you changed the SAMBA user password? What password did you specify? Usually this would not needed and you should be able to connect out of the box. At least this is how it is working on Windows.