Cannot connect serial port(uart) to Node red Raspberry Pi

Exelent my dear.
Everytyng is done!!!
Sorry for my bad english.


Ah, thanks for reporting. We need to add this user to that group on Node-RED install already: DietPi-Software | Node-RED: Add service user to dialout group · Issue #5974 · MichaIng/DietPi · GitHub

Shouldn’t ttyAMA0 be a toggle device? Thank you.

Only the primary UART can be toggled on or off, and on the Zero W the mini UART is the primary one.

Understood. I want to share that everything works. The method I used in Node red is wrong, here is the correct approach.
Thanks again.

1 Like

Done with: Beta v8.12.1 by MichaIng · Pull Request #5984 · MichaIng/DietPi · GitHub
Release will be done the next minutes.

1 Like

I want to note a very important point, I added these two lines at the bottom of /boot/config.txt to make everything work as expected.

# Disable Bluetooth
Even though bluetooth is turned off in dietpi-config without adding these two lines ttyAMA0 does not work.
Shouldn’t dietpi-config have more bluetooth options, or default to include these two lines in config.txt