[Bug?] SoftEther VPN high CPU


I’m using a Raspberry Pi model B (512MB RAM), first generation and it seems that SoftEther is using all the CPU resources, the VPN connection is just reeaaalllyy slow (pings are even 1000+ ms). I followed the steps that are on the forum (http://dietpi.com/phpbb/viewtopic.php?f=8&t=5&start=10#p57).
This is what htop shows:

The Pi is even overclocked to 1 GHz…

I don’t know if this is a bug or just that the Raspberry Pi 1 is just not fast enough.

I’ve only tried this on my RPiv2, but its been a while since I tested it.

Once i’ve released RPi-Jessie (today), I’ll run a test on my RPi 256mb and see if I can replicate it sometime this week.

Are you getting the 100% cpu usage with a active VPN connection, or, idle?

Active. I was not activly using the VPN, I justed SSHed into the Pi via VPN.

I’d like to add some information:
I had virtual DHCP enabled on the server because the client couldn’t get an IP address from the DHCP server that runs on the Raspberry Pi.

I’ve tried it on an other Pi (with Jessy), installed SoftEther and it works fine without virtual DHCP because I use an external DHCP server. When I enable the virtual DHCP server, CPU goes 100%.

Raspberry Pi can’t handle NAT. If I disable that, it works just fine.
Maybe you could add some sort of warning. I don’t have a Pi2, so I can’t test it if it works there.

This topic can be closed.

Interesting, could be some weird and wonderful network setting that is causing it?

Is the NAT part of the DHCP server installation you had running? I’ll try to run some tests on the RPi2.

I only know, if you enable this:

It’s using 100% CPU on my Pi.