[Bug?] Sabnzbd

There’s what might be a tiny mistake in the sabnzbd.ini file which make it unreachable from anywhere but the system that’s running it; under host it’s set to, rather than
I couldn’t figure out if this was intended behaviour from the changelog and software list on the forums, but considering all other sharing related apps are defaulted to a setup that’s reachable on the LAN, i suspect it’s a small mistake.

Also, when set to port 8080 it becomes unreachable, i suspect this happens when Pi-Hole (or any other application that uses the same port) is installed, so perhaps it’s better to make it’s standard port something else ?

(For reference, i simply changed the host and port number in the .ini and could instantly connect, so if anyone else is having issues : check the .ini file in /etc/sabnzbd/ )


Thanks for report. We actually set those values during installation.

I believe this issue is due to the way we need to launch Sabnzbd, to generate the initial config and unique keys (it cant be done before hand, breaks initial wizard setup https://github.com/Fourdee/DietPi/issues/865#issuecomment-293228593).

It may be that the config wasn’t fully generated and overwritten by the program after a service restart:

It worked for me on test install with Odroid C2. I’ll add the config code to the online doc:
If you can run the code in above link under section “Web interface not loading / Unable to access:”, will resolve.

I’ll also add some additional delay during config stage, should prevent this from occurring in v150+.

Considering how much trouble Sabnzbd always gave me when compiling from source, i’m rather inclined to believe it’s being a pain in the ass about it for no good reason whatsoever.
Because that’s exactly how it always worked with me… :imp:

On a related note, unrar-free as installed alongside Sabnzbd will not extract multipart archives, we’re stuck using unrar-nonfree for that.
There’s a decent new/inexperienced user friendly guide on how to install unrar-nonfree on StackExchange’s Raspberry Pi hub, in case anyone needs some help getting it installed.

Yep, we chose to stay with apt for unrar binaries.

RPi as you know is unrar-free, all others will install the nonfree version: