bug: dietpt-services

everytime i use dietpi-services for to stop a random services the script exec this command too:
[ OK ] DietPi-Services | ncc maintenance:mode --on

and let nextcloud in maintenance mode for ever, even if i finish in dietpi-services and close it

need to launch from shell ncc maintenance:mode --off everytime i use dietpi-services

Hi,

many thanks for your message. There is basically a similar report https://dietpi.com/forum/t/stopping-qbittorrent-enables-nextcloud-maintenance-mode/3876/1

What service you like to stop? If possible I would try to replicate the issue.

i think its easy to replicare, all my services stop nextcloud too

rpi-monitor
nmbd
smbd
redis-server
mariadb
php7.3-fpm
lighttpd
qbitttorent
docker
ssh
pihole-FTL
openvpn

this is all my services up, and everyone i stop script do ncc maintenance:mode --on and leave it set to on for ever
i manually off the maintenacemode everytime in this log before try to stop something

root@DietPi:~# dietpi-services
[  OK  ] DietPi-Services | ncc maintenance:mode --on
[  OK  ] DietPi-Services | stop : rpimonitor
[  OK  ] DietPi-Services | restart : rpimonitor
[  OK  ] DietPi-Services | ncc maintenance:mode --on
[  OK  ] DietPi-Services | stop : nmbd
[  OK  ] DietPi-Services | restart : nmbd
[  OK  ] DietPi-Services | ncc maintenance:mode --on
[  OK  ] DietPi-Services | stop : smbd
[  OK  ] DietPi-Services | restart : smbd
[  OK  ] DietPi-Services | ncc maintenance:mode --on
[  OK  ] DietPi-Services | stop : redis-server
[  OK  ] DietPi-Services | restart : redis-server
[  OK  ] DietPi-Services | ncc maintenance:mode --on
[  OK  ] DietPi-Services | stop : mariadb
[  OK  ] DietPi-Services | restart : mariadb
[  OK  ] DietPi-Services | ncc maintenance:mode --on
[  OK  ] DietPi-Services | stop : php7.3-fpm
[  OK  ] DietPi-Services | restart : php7.3-fpm
[  OK  ] DietPi-Services | ncc maintenance:mode --on
[  OK  ] DietPi-Services | stop : lighttpd
[  OK  ] DietPi-Services | restart : lighttpd
[  OK  ] DietPi-Services | ncc maintenance:mode --on
[  OK  ] DietPi-Services | stop : qbittorrent
[  OK  ] DietPi-Services | restart : qbittorrent
[  OK  ] DietPi-Services | ncc maintenance:mode --on

ok seems still not fixed. I will open a GitHub issue out of it. For the time being, pls use systemctl

systemctl stop <service>

However if you like using dietpi-services, pls use:

dietpi-services start <service>

and not

dietpi-services restart <service>

Using start will enable NextCloud as well, while restart will just restart the particular service

root@DietPi3:~# dietpi-services restart qbittorrent

 DietPi-Services
─────────────────────────────────────────────────────
 Mode: restart qbittorrent

[  OK  ] DietPi-Services | restart : qbittorrent
root@DietPi3:~# 
root@DietPi3:~# 
root@DietPi3:~# dietpi-services start qbittorrent

 DietPi-Services
─────────────────────────────────────────────────────
 Mode: start qbittorrent

[  OK  ] DietPi-Services | start : qbittorrent
[  OK  ] DietPi-Services | ncc maintenance:mode --off

GitHub open: https://github.com/MichaIng/DietPi/issues/3740

a fix will be implemented with upcoming DietPi release 6.32.

https://github.com/MichaIng/DietPi/commit/2fd9a8744622a8c5a4589cbfe78a4e2df88895b1

thanks for your work, really