apt auto completion not working

I found that a new refreshed install of DietPi does not come with apt auto completion working by default, to throublesoot this do this actions:

Run:
dietpi-config

Then go to:
4 - Advanced Options
APT-Cache

And then:
set the two options (APT cache and APT lists) to [On disk]

After that do:
sudo apt update

Now the command ‘sudo apt install ja[TAB][TAB]’ will work!

MichaIng
Maybe you can have a look. System default is APT cache and APT lists set to [On disk] according the system dialog. However APT cache is set to [Disabled] . Probably it was deactivated to reduce I/O and SD Card usage. But I’m not sure.