Any logs during install? (UART0 unavailable)

I have a NanoPi Neo Air (Allwinner H3 SoC) with onboard wifi and a serial interface. Unfortunately during some late hour hacking I managed to accidentally connect 5V onto its TX pin, I think effectively screwing up its UART0. I can no longer connect to it via a USB to TTL Serial cable (

Looking at the NeoPi Nano Air’s pinout diagram, it seems to have more UART devices (UART1 and UART2 even) so I was trying to enable these in dietpi.txt (using the serial_console_enabled option) but did not have any luck when I was trying to get some output via the serial interface.

Another idea I had was to actually try to hook up the board via the wifi (setting it up in dietpi.txt), however I don’t seem to get it to connect to the router. (I’ve put it quite close, ran an IP scan over the network too, ensured that 2.4GHz was enabled on the router, etc.) I tried this with setting up both static and non-static IP in dietpi.txt. No luck.

When booting up, the LEDs are flashing in a normal way, then they seem to speed up and then back to normal. I can only assume there’s some IO happening on the SD card during this time, perhaps the board even restarts (I can’t confirm tho).

I’ve taken out the SD card and seen that the originally ~390MB partition was successfully expanded to the whole capacity of the SD ard (16G). This tells me that the on-board SoC is not totally broken, perhaps the UART device is dead but not the whole board.

The Getting Started guides mention two reboots on the board, however I think there might be only one, which tells me that something is stuck during install. (Tried both with and without autoinstall.)

I wonder if there’s a way to get some debug messages out of the board. Or logs stored somewhere. (I could plug the SD card back into a Mac and read the logs in linux)

Any help would be appreciated. Thank you.