8.2.2 RPi B UART connection not writable

Hi,

i have a NAS device connected to the UART Pins 6, 8 and 10 on my RPi B to read and write to the serial console on the NAS.
This connection was working when i was on DietPi v6.32.2.
As the system stated that i should upgrade i tried that unfortunately without success because of different errors (time sync error, not enough space on my 4GB SD-Card etc.).
As this install was mostly a clean install without much changes i decided to just write the new version to the SD-Card and starting over.
So far everything runs fine but i cant write to the serial connection via picocom which was possible on version 6.32.2.
I disabled the serial console in dietpi-config and restarted, i also tried disabling serial console and UART and enabling only UART after reboot.
I can only read but no input from my side goes to the console.
Unfortunately i can’t find which might be wrong so i am asking here if someone might have an idea.

I would be happy if someone could point me in the right direction.