7.8.2 one.one.one.one Ping Cron error message...

Hello group, after the last update I receive the following message:

Cron root@PI test -x /usr/sbin/anacron || { cd / && run-parts --report /etc/cron.daily; }

/etc/cron.daily/dietpi:
[FAILED] DietPi-Update | Checking DNS resolver
 - Command: ping -nc 1 -W 5 one.one.one.one [FAILED] DietPi-Update | Unable to continue, DietPi-Update will now terminate.

Any clue on what this one might be?

looks like you are not able to pink IP of Cloudflare global DNS provider. Usually this is a local issue or something is blocked. Probably by your ISP. Could you try following

ping -nc 1 -W 5 one.one.one.one
ping -nc 1 -W 5 1.1.1.1

Hi, tested and both resolve with Ping .

root@PI:~# ping -nc 1 -W 5 one.one.one.one
PING one.one.one.one(2606:4700:4700::1001) 56 data bytes

--- one.one.one.one ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms



root@PI:~# ping -nc 1 -W 5 1.1.1.1
PING 1.1.1.1 (1.1.1.1) 56(84) bytes of data.
64 bytes from 1.1.1.1: icmp_seq=1 ttl=54 time=12.4 ms

--- 1.1.1.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 12.380/12.380/12.380/0.000 ms

issue seems to be with IPv6 stack on your side. I would recommend to disable IPv6 if not needed.

As you can see, you have 100% packet loss on using the domain name via IPv6

OKI see that. un fortunately I cant shut off IPV6, my upstream provider requires it. Anyway in the code the cron is calling to set to default to IPV4?

For the DietPi script it doesn’t matter if it is IPv4 or IPv6 as we do a simple ping to a domain like one.one.one.one

ping -nc 1 -W 5 one.one.one.one

There is nothing magic or self developed on it, as ping is a global available command. You would need to have a look on your network and or configuration why IPv6 is not fully functional. For testing you could switch of IPv6 on DietPi using dietpi-config

Another option is to check if you are able to ping something else like Quat9

ping -nc 1 -W 5 dns9.quad9.net